Public full node installation using AWS Cloud

Hi all…

I am trying to install public full node using AWS Cloud but I am struck in one step that is exactly this command “cargo install --git GitHub - aptos-labs/aptos-core: A layer 1 for everyone! aptos --branch devnet” whenever I try this command face this error:

error: could not compile libsecp256k1

Caused by:
process didn’t exit successfully: rustc --crate-name libsecp256k1 --edition=2018 /root/.cargo/registry/src/github.com-1ecc6299db9ec823/libsecp256k1-0.7.1/src/lib.rs --error-format=json --json=diagnostic-rendered-ansi,artifacts,future-incompat --crate-type lib --emit=dep-info,metadata,link -C opt-level=3 -C embed-bitcode=no -C debuginfo=2 -C overflow-checks=on --cfg 'feature="default"' --cfg 'feature="hmac"' --cfg 'feature="hmac-drbg"' --cfg 'feature="sha2"' --cfg 'feature="static-context"' --cfg 'feature="std"' --cfg 'feature="typenum"' -C metadata=681be0f9e77cf024 -C extra-filename=-681be0f9e77cf024 --out-dir /tmp/cargo-installOUndsP/release/deps -L dependency=/tmp/cargo-installOUndsP/release/deps --extern arrayref=/tmp/cargo-installOUndsP/release/deps/libarrayref-da8666f3744e76ec.rmeta --extern base64=/tmp/cargo-installOUndsP/release/deps/libbase64-b072e8c0609c96d5.rmeta --extern digest=/tmp/cargo-installOUndsP/release/deps/libdigest-f1cc83d59876cef3.rmeta --extern hmac_drbg=/tmp/cargo-installOUndsP/release/deps/libhmac_drbg-0cdd8bd3fc3dc374.rmeta --extern libsecp256k1_core=/tmp/cargo-installOUndsP/release/deps/liblibsecp256k1_core-361ada25efcdc13f.rmeta --extern rand=/tmp/cargo-installOUndsP/release/deps/librand-aa34e7af4f99fa98.rmeta --extern serde=/tmp/cargo-installOUndsP/release/deps/libserde-4c557766832095c4.rmeta --extern sha2=/tmp/cargo-installOUndsP/release/deps/libsha2-ffc13aedef6de3a5.rmeta --extern typenum=/tmp/cargo-installOUndsP/release/deps/libtypenum-aba135d0335ec868.rmeta --cap-lints allow (signal: 9, SIGKILL: kill)
warning: build failed, waiting for other jobs to finish…
error: failed to compile aptos v0.3.6 (https://github.com/aptos-labs/aptos-core.git?branch=devnet#d2369dc1), intermediate artifacts can be found at /tmp/cargo-installOUndsP

please anyone help me to solve this error

4 Likes

Wow this huge

3 Likes

Very huge indeed

2 Likes

Yes mate :heart:

2 Likes

Your json libray throws an error. Can you check it

1 Like

Super elated to see yoy launch your project. All the best mate