Is there a standard naming convention for Move yet? Digging through the example code in aptos-core, it appears inconsistent. Here are the naming conventions I propose:
Named-addresses use snake_case, while module names use CamelCase. (i.e., module my_token_name::TokenModule)
Functions use snake_case, while structs use CamelCase.
Package-names use CamelCase. (Although I don’t know if package-names really do anything yet.)
Constants and errors are SCREAM_SNAKE_CASE.
Let me know your thoughts or if Move has an adopted naming-convention already that just isn’t being followed yet.