Full Node - Error 400 - Fullnode.yaml

Hello everybody,

I started a fullnode without problems, the node syncs without problems.

But when I go to assign a network identity and edit the Fullnode.yaml file by entering the identity details the node goes online, but it stops synchronizing and generates several 400 errors.

The node started following this Fullnode.yaml configuration:

base:
    # Update this value to the location you want the node to store its database
    data_dir: "/opt/aptos/data"
    role: "full_node"
    waypoint:
        # Update this value to that which the blockchain publicly provides. Please regard the directions
        # below on how to safely manage your genesis_file_location with respect to the waypoint.
        from_file: "./waypoint.txt"

execution:
    # Update this to the location to where the genesis.blob is stored, prefer fullpaths
    # Note, this must be paired with a waypoint. If you update your waypoint without a
    # corresponding genesis, the file location should be an empty path.
    genesis_file_location: "./genesis.blob"

full_node_networks:
    - discovery_method: "onchain"
      # The network must have a listen address to specify protocols. This runs it locally to
      # prevent remote, incoming connections.
      listen_address: "/ip4/0.0.0.0/tcp/6180"
      network_id: "public"
      # Define the upstream peers to connect to
      seeds:
        {}


api:
    enabled: true
    address: 0.0.0.0:8080

The node functions and synchronizes

With this configuration:

base:
    # Update this value to the location you want the node to store its database
    data_dir: "/opt/aptos/data"
    role: "full_node"
    waypoint:
        # Update this value to that which the blockchain publicly provides. Please regard the directions
        # below on how to safely manage your genesis_file_location with respect to the waypoint.
        from_file: "./waypoint.txt"

execution:
    # Update this to the location to where the genesis.blob is stored, prefer fullpaths
    # Note, this must be paired with a waypoint. If you update your waypoint without a
    # corresponding genesis, the file location should be an empty path.
    genesis_file_location: "./genesis.blob"

full_node_networks:
    - network_id: public
      discovery_method: "onchain"
      identity:
        type: "from_config"
        key: "<My Private Key>"
        peer_id: "<My_Public_Key>"
      # The network must have a listen address to specify protocols. This runs it locally to
      # prevent remote, incoming connections.
      listen_address: "/ip4/0.0.0.0/tcp/6180"
      # Define the upstream peers to connect to
      seeds:
        {}


api:
    enabled: true
    address: 0.0.0.0:8080

The node goes online, but does not synchronize and generates several 400 errors.

The node goes online, but does not synchronize and generates several 400 errors.

Obviously in the key field: I enter my private key and in the peer_id field: I put my public key without the initial “0x”.

Where am I doing wrong?

Thank You